Blank Page Screen In OWA/EAC Exchange 2013/2016/2019 Server

MASEE Solution Guide - Technical Dept Head
CERTIFIED EXPERT
Most Valuable Expert2017.
Exchange Server, Windows Server, Active Directory, Virtualization, Skype for Business and Email Migration Expert.
Published:
Edited by: Andrew Leniart
This article will help you fix blank screen when you try to login to EAC or OWA.

OWA
OWA (Outlook Web App) is a browser-based email client, i.e. Outlook on the web. You can access your Exchange mailbox using a web browser.  

Since Exchange 2003 we called it as using Exchange Web Access which we accessed by URL https://mail.domain.com/exchange We can change the URL though. 

And When Exchange 2007 released we called it as OWA (Outlook Web Access) and we accessed by URL. https://mail.domain.com/owa. When Exchange 2010 was released, there was no difference in the name and URL. 

In Exchange 2013 and higher versions it is called as OWA (Outlook Web App) with no change in URL i.e. https://mail.domain.com/owa

ECP/EAC
In Exchange 2007 and 2010 we used to manage Exchange through Exchange Management Console. (EMC). In Exchange 2013 and higher versions, we manage Exchange through a web-based console which is called Exchange Admin Center ( EAC). We open the EAC using the URL "http://localhost/ecp/?exchclientver=15"  from the server. If you access from another PC in the network you will have to use the IP or servername, i.e. "http://exchserver/ecp/?exchclientver=15"  or "http://192.168.0.100/ecp/?exchclientver=15". 

OWA/EAC blank screen 
There are cases when Exchange Admins update Exchange server with a CU (Cumulative Update) or SP (Service Pack) and get a blank screen when they try to login to OWA or EAC. If you are trying to log in using browsers to access the Exchange Control Panel (ECP) and Outlook Web Access (OWA) shows a blank white website page, then your issue will most likely be fixed if you go through this article. Because, here we will discuss the most common reasons and techniques used to resolve the problem of Exchange 2016, 2013, 2010 of ECP / OWA showing a blank page after login.

This issue usually occurs in Exchange Server 2016. When an Exchange Administrator accesses Exchange Admin Center (EAC) or a user accesses Outlook Web App (OWA) and gets a blank screen when the username and password is entered.

The most common reasons are the following.

  1. The binding is installed incorrectly.
  2. The binding doesn’t have a certificate assigned. 

  3. The binding contains incorrect information. 


Default Website  
In the Default Website, ensure the certificate binding is correct. I.e. 3rd party certificate is assigned to HTTPS.
 

Exchange Backend  
Now please make sure the Exchange Backend certificate binding is correct. I.e. Self signed certificate is assigned to HTTPS with port 444.

Right Click Exchange Backend Website and click "Edit Binding"





If the self signed certificate is missing, run the following command to issue a self signed certificate.
New-ExchangeCertificate

Once you have assigned both the certificate and verified, please reset IIS using the following command.
iisreset /noforce
Please try to login after resetting IIS. You should now see your login screen.

I have written articles to cover the Exchange administration on all versions of Exchange (see below):



1
1,150 Views
MASEE Solution Guide - Technical Dept Head
CERTIFIED EXPERT
Most Valuable Expert2017.
Exchange Server, Windows Server, Active Directory, Virtualization, Skype for Business and Email Migration Expert.

Comments (0)

Have a question about something in this article? You can receive help directly from the article author. Sign up for a free trial to get started.

Get access with a 7-day free trial.
You Belong in the World's Smartest IT Community